[UK Only] Amendment To Facebook's Payout Date Range.
Incident Report for givepanel
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 09:32 UTC
Update
We believe this was a temporary change and payout periods are now back to normal.

Facebook runs 2 payouts every month for transactions (donations) between:

1) 1st to 15th of the month
2)16th to last day of the month
Posted Jul 21, 2023 - 09:31 UTC
Investigating
Some Customers in the UK who are enrolled with Meta Pay and usually receive payment every two weeks, have reported receiving a much larger payout from Facebook for the payment range of 16th-31st of January.

Instead of it being a payout for 16th-31st of January, the payout was for donations from 16th of January to 15th of February.

We are investigating if this is a permanent or one off change.

If you have any questions, we recommend contacting Facebook's Nonprofit support - https://www.facebook.com/help/contact/513795398968461
Posted Mar 06, 2023 - 15:39 UTC
This incident affected: Facebook Giving Tools [3rd Party].