[GLOBAL] Facebook Data Bug - Duplicate IDs Causing Donation Duplication
Incident Report for givepanel
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 10:54 UTC
Monitoring
Meta have confirmed they have pushed out a fix to ensure donations are only assigned one Transaction ID.

We will be continuing to monitor customers data over the coming days to verify this has been resolved.
Posted Aug 16, 2023 - 09:15 UTC
Investigating
Issue with Facebook Data:

We’ve identified a significant issue with Facebook’s transaction data system.

Some donations are receiving multiple transaction IDs, disrupting the unique identification process.

Each donation should have a distinct Transaction / Payment ID assigned by Facebook. However, a bug in Facebook’s Transaction Data is causing discrepancies between the IDs Facebook are assigning donations that come into your account in realtime vs other import methods such as the Multi Day Transaction Report.

Due to the critical nature of Transaction IDs for accurate tracking, this problem has led to donations with different IDs being treated as separate transactions in GivePanel.

Consequently, importing data using both real time donations alongside other import methods might have introduced duplicate entries.

How GivePanel Is Helping:

Our engineering team, including our Head of Engineering, have acted swiftly to prevent this issue from affecting your GivePanel account any further. We’re implementing measures to safeguard against duplicate donation records.

Simultaneously, we have been meeting directly with Meta to not only bring this issue to their attention, but have them take action to address the root cause of this bug as a priority.

For the data that has been impacted in your GivePanel account, we’re committed to assisting you in removing duplicate donations. We appreciate your understanding as we work to resolve this situation caused by the Facebook data bug. Your partnership is invaluable, and we’re dedicated to delivering a seamless experience moving forward.
Posted Aug 11, 2023 - 08:46 UTC
This incident affected: Facebook Giving Tools [3rd Party].